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Sissejuhatus

Mõningate tähtsamate MS Project’i terminite eestikeelsed vasted:
project -	projekt
goal -	eesmärk, siht
scope -	eesmärkide ja nende teostamiseks vajalike põhitööde loetelu
resource -	ressurss (töötaja, seade, ruum, materjal vm)
task -	töö, ülesanne
subtask -	tööde grupp
phase -	etapp
milestone -	vahekokkuvõte
deadline -	valmimistähtaeg
assumption -	eeldus
outline -	hierarhiline (liigendatud) tööde loetelu
shedule -	ajakava

Juhtimiseks jaotatakse keeruline projekt alamprojektideks või väiksemateks etappideks (phase), need omakorda töödeks (task), millest mõned saavad alata alles pärast eelmise lõppemist, teised võivad toimuda paralleelselt. Igale tööle määratakse kestus ja eraldatakse ressursid.
Töö maksumus leitakse ressursi kasutamise ajaühiku hinna ja töö kestuse korrutisena. Tööde maksumuste summa annab projekti maksumuse. 
Töö käigus tuleb kogu aeg kontrollida tähtaegadest kinnipidamist, ressursside kasutamist ja etappide tegelikku alustamise ja lõpetamise aega. Nende kontrollimisega täpsustatakse ka ajakava.
MS Project’i andmebaasis võib säilitada kuni 1000 alamprojekti andmeid. Tööde ja etappide arv on piiratud ainult kasutatava mälu mahuga. Saab teha viiteid Office 2000 dokumentidele. 

Projekti juhtimises võib eristada kolme etappi:
1. planeerimine;
2. kontrollimine;
3. lõpetamine.
MS Project abistab 1. ja 2. etapi jooksul.
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Algab projekti defineerimisest,  kus võetakse vastu kõik strateegilised otsused – määratakse eesmärgid ja nende saavutamiseks vajalike põhitööde loetelu, olemasolevad ressursid ja ajalised piirangud. Eesmärgid peavad olema püstitatud piisava täpsusega. Eesmärkide ja nende saavutamiseks vajalike tööde loetelu kohta kasutatakse terminit scope.
Eeldused (assumptions) on projektijuhi ja teiste spetsialistide arvamused, hinnangud ja oletused tööde käiku mõjutavate tegurite kohta. Mõned tingimused võivad tuleneda väliskeskkonnast ja neid tuleb arvestada kui neid soovitavas suunas muuta ei saa.
Hea plaani koostamiseks on vaja:
· määrata kõik tööd (tasks) ja kes neid teeb;
· määrata tööde mahud ja kestused;
· määrata tööde järjekord;
· määrata piirangud, millal mingi konkreetne töö peab algama.
Projekti koostamine tähendab kompromissi leidmist tähtaja, raha ja seatud ülesannete vahel.
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Projekti tööde käigu kontrollimiseks tuleb:
· võrrelda tegelikke andmeid plaanilistega;
· kontrollida olemasolevaid ressursse ja nende kasutamist;
· määrata probleemid, mis võivad põhjustada ajakavast mahajäämist;
· teha muudatusi, mis võimaldavad tähtaegadest kinni pidada.
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Pärast tööde lõppemist tuleb tööde käiku analüüsida, määrata, mis läks hästi ja mis mitte. MS Project võimaldab:
· salvestada algse plaani ja selle lõppvariandi;
· salvestada ressursside ja tööde kohta kirjapandud märkused.
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Esialgse plaani koostamine

Uut projekti võib alustada failimenüü korraldusega New, mis kuvab tühja Gantti diagrammi vaate. 
[image: ]

Sellel vaatel on akna vasakus paanis tabel Entry, mis sisaldab tööde loetelu, kestused, algus- ja lõpukuupäevad ning eelneva töö numbri, mille abil tööd seostatakse. Plaani koostaja sisestab tabelisse andmed. Parempoolses plaanis on diagramm, millel tööde pikkusi näitavad ajateljele paigutatud horisontaalribad (bar).
Veerus Task Name paiknevad tööde nimed, mis sisestatakse esimesena, veerus Duration nende kestused (vaikimisi üks päev).
Tööde nimede ees paikneb indikaatorite veerg, milledega tähistatakse töö lõpetamist („linnuke“), kitsendavate tingimuste, märkuste või hüperlinkide olemasolu.
Akna parempoolses paanis on nädalate veerud, kus on tähtedega märgitud nädalapäevad. 
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Esimese sammuna tuleb määrata projekti tööde alustamise kuupäev: Project -> Properties -> Project Information -> Start Date (tööde alustamise kuupäev). 
Projekti ajakava koostamisel lähtutakse vaikimisi alguskuupäevast, kuid vajaduse korral võib lähtuda ka lõppkuupäevast (näiteks näituse korraldamine).
Väljalt Schedule from saab määrata, kas plaanimist alustatakse algus- või lõppkuupäevast.
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Teise sammuna tuleb sisestada tööde loetelu. Veeru Task Name igale reale tipitakse ühe töö nimetus. Need olgu lühikesed, kuid selged. Tööde kestused sisestatakse hiljem. Sisestada võib ka etappide, tööde gruppide ja vahekokkuvõtete (milestones) nimed (viimaseid käsitletakse kui fiktiivseid töid, mille kestuseks määratakse null päeva).
Tööde loetelu koostamisel tuleb lähtuda järgmisest:
· sisestage ainult projekti lõpetamise seisukohalt olulised tööd;
· tööd olgu piisavalt detailsed ja kogu projekti pikkusega võrreldes lühikesed, kuid pikemad kasutatavast ajaühikust (vaikimisi 1 päev);
· lisaks töödele sisestage ka etappide, tööde gruppide ja vahekokkuvõtete nimed.
[image: ]
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Tähtsamate etappide lõppu võib lisada rea vahekokkuvõtte (milestone) jaoks. Tavaliselt esitatakse siis ka tellijale aruanne. Tööd, mille pikkus on null, tähistatakse Gantti diagrammil rombiga. Erinevalt teistest töödest, tippige vahekokkuvõtte puhul (kohe pärast nime tippimist) väljale Duration selle kestuseks 0.
[image: ]
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Tööde kestuse sisestamine on projekti planeerimise kolmas etapp. Tööde kestused on projekti täitmiseks kuluva aja arvestamise aluseks. Tööde järjekorda esialgu ei arvestata. Töö kestuse hulka ei arvutata vabu päevi. Kui soovitakse planeerida pidevat tööd, tuleb töö kestuse ühiku ette lisada täht „e“, nt edays.
[image: ]
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Et pikk loetelu oleks ülevaatlikum, tuleb tööd jaotada etappidesse ja gruppidesse. Parema ülevaatlikkuse huvides tuleb tööde loetelu liigendada (outline), nihutades gruppide nimed etappide nimede suhtes sammu võrra paremale. Gruppi kuuluvate tööde nimed tuleb omakorda nihutada grupinime suhtes sammu võrra paremale. Seostatud tööde korral summeerib MS Project üksikute tööde kestused töögrupi (summary task) nime taha, kui iga uus töö algab pärast eelmise lõppemist.
[image: ]

Nihutamiseks tuleb vajalikud read hiirega märgistada ja klõpsata tööriistaribal nupul Indent 
([image: ]) või Outdent ([image: ]).
Plaani vaatamisel võib tööde loetelu kuvada või printida soovitava detailsusega (ainult etapid või etapid ja grupid jne).
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Neljanda etapina tuleb iga töö täitmiseks eraldada vajalikud ressursid: töötajad, seadmed, ruumid jne.
MS Project’i abil võib koostada olemasolevate ressursside loetelu (resource sheet). Loetelu sisaldab iga ressursi nime ja maksimaalse aja, mille jooksul seda saab kasutada.
Sageli on kasulik ressursina kasutada mitmest ühesuguse kvalifikatsiooniga töötajast koosnevat töörühma, mille kohta kasutatakse terminit set of resources. 
Kombinatsiooni mitmest töörühmast ja/või erineva kvalifikatsiooniga üksiktöötajatest nimetatakse resource group. Selle nimi sisestatakse tabelis veergu Group.
[image: ]
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Ressursside planeerimisel on aluseks kalender. Vaikimisi kasutatakse baaskalendrit, milles puhkepäevad on ainult nädalalõpud. Tööpäev algab kell 8 ja lõpeb 17, lõuna on 12 – 13. Baaskalendrit saab muuta, määrates teistsuguse tööaja ja lisades kalendrisse riiklikud pühad.
Iga projekti jaoks võib lisaks baaskalendrile teha ühe või mitu spetsiaalkalendrit. Selliste ressursside eraldamise korral tuleb näidata, millist kalendrit antud ressursi jaoks kasutatakse.
Kalendri saab avada Project -> Change Working Times, mis avab järgmise akna:
[image: ]

Muudetud baaskalendri salvestamiseks klõpsake nupul New ja valige Create a new calendar. See kalender kehtib vaikimisi antud projekti piires iga ressursi jaoks.
Erikalendri jaoks tippige samasse aknasse uue kalendri nimi ja klõpsake nupul OK. Tehke kalendris vajalikud muudatused ja klõpsake uuesti OK. Ressursside tabelis tuleb näidata, millist kalendrit iga ressurss kasutab, vaikimisi kasutatakse projekti baaskalendrit.
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Ressursside kinnistamine
Avage Gantti diagramm ja klõpsake nupul Resources ->Assign Recources [image: ]. 
[image: ]

Avanevasse dialoogiaknasse valige üks loetelus olevatest ressurssidest ja klõpsake nupul Assign. Sama töö jaoks võib eraldada mitu ressurssi. Ressursi vabastamiseks tuleb klõpsata ressursi nimel ja siis nupul Remove.
Ressursi asendamiseks teisega tuleb loetelust valida vajalik ressurss, klõpsata asendatava ressursi nimel ja siis nupul Replace.
Kui mõnel üksiktöötajal on valitud kalendrist erinev tööaeg, tuleb redigeerida valitud kalendrit selle konkreetse ressursi jaoks (valida ressursside tabelis ressursi nimi ja klõpsa tööriistariba nupul Resource – Properties - Information. Avaneva dialoogiakna lehel Working Time tuleb kalendris valida vajalikud kuupäevad ja muuta tööaega (Use default; Nonworking time või Nondefault working time).
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Tööde loetelus paiknevad tööd tegemisjärjekorras. Kõik tööd algavad vaikimisi projekti alguskuupäevast. Reaalse ajakava jaoks on vaja tööd omavahel seostada, st näidata, kiuidas vaadeldava töö algus on seotud eelneva tööga (predecessor). MS Project kasutab nelja seosetüüpi:
	Seose tüüp
	Seose tähis
	Gantti diagrammil

	Töö algab pärast eelneva töö lõppu
	Finish-to-Start (FS)
	▀▀▄▄ 

	Töö algab koos eelneva tööga
	Start-to-Start (SS)
	▄▄
▀▀▀▀

	Töö lõpeb koos eelneva tööga
	Finish-to-Finish (FF)
	      ▄▄
▀▀▀▀

	Töö lõpeb eelneva töö algusega
	Start-to-Finish (SF)
	     ▄▄
▀▀


Enam levinud on FS seosetüüp, mida kasutatakse vaikimisi.
Tööde seostamiseks tuleb need Gantti diagrammil märgistada ja klõpsata tööriistaribal nupul Link Tasks [image: ]. Kui märgistatavad read ei paikne üksteise järel, kasutada Ctrl-klahvi. Seost tähistab ühe töö lõppu teise algusega ühendav joon.
Kui vaikimisi valitud seosetüüp ei rahulda, tuleb seda muuta. Selleks tehke topeltklõps Gantti diagrammil töid ühendaval joonel ja tehke sobivad muudatused.
[image: ]

Väljale Lag võib tippida intervalli (lag time), mis jääb lõppenud ja järgneva töö vahele või mille võrra töö algus ennetab (lead time) eelneva töö lõppu (miinus-märgiga).
Pärast seosetüüpide näitamist kalkuleerib MS Project kõigi tööde algus- ja lõpptähtajad ning muudab Gantti diagrammil olevate ribade paigutuse.
Töö algukuupäeva võib muuta, pukseerides vastava riba hiirega horisontaalsuunas sobivale kohale.
Mõnikord on vaja, et teatud tööd algaksid või lõpeksid kindlal kuupäeval. MS Project omistab vaikimisi igale tööle sobiva piirangu (constraint).
Töö piirangu muutmiseks avage Gantti diagramm, klõpsake töö nimel ja siis Task -> Properties -> Information [image: ]. Lehe Advanced välja Constarint  Task loetelust Constraint Type valige sobiv piirangutüüp.
Jäigad piirangud võivad tülikaks osutuda: eelnevad tööd võivad jäigalt määratud tähtajaks mitte lõppeda, ressursse võidakse üle koormata. 
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Kui ressursid on kinnistatud ja tööde kestus määratud, on võimalik arvutada töö maksumus, mis sõltub kasutatava tööjõu kuu- või tunnipalgast, materjalide maksumusest ja kaudsetest kuludest. Lihtsamatel juhtudel võib lähtuda ressursi kasutamise ajaühiku hinnast, mis peab lisaks palgale sisaldama ka kaudseid kulusid.
MS Project lubab iga ressursi kohta sisestada kas ühekordse kasutusmaksumuse (pre-use costs) või kasutustunni maksumuse (hourly rate).
Kasutustunni maksumus võib pikema projekti korral muutuda, mis võimaldab arvestada plaanilist töötasu tõusu. Standardset tunnimaksumust  (standard rate ehk Std. Rate) kasutatakse normaalsel tööajal, ületunni maksumust (overtime rate ehk Ovt. Rate) kasutatakse, kui töönädal ületab seadusega kehtestatu või töötatakse väljaspool tööaega.
Iga ressursi kohta võib koos tunnimaksumusega või ilma selleta rakendada ka ühekordset kasutusmaksumust (cost per use ehk Cost/Use) (seadme rentimisel nõutakse ühekordset tasu selle kohaletoimetamise eest ja lisaks tasu iga kasutustunni eest).
Maksumuse sisestamiseks tuleb avada ressursside tabel, tippida selle veergudesse St. Rate, Ovt. Rate ja Cost/Use iga ressursi kohta vajalikud maksumused ja vajutada Enter.
[image: ]Kui kasutatakse korduvalt sama ühikmaksumusega ressursse, võib ühikmaksumuse sisestada File -> Options lehelt Advanced.
Default standard rate ja Default overtime rate tippige vajalikud väärtused.













Kui eri ressursid töötavad erineva tunnitasu alusel, siis tuleb tunnitasud sisestada ressurside tabelisse (Resource Sheet) ja trükkida avaneva tabeli veergudesse Std. Rate ja Ovt. Rate.
Ületunnid ei lisandu varem planeeritud töö mahule, ületunnitööna näidatud tundide arv on osa üldisest töömahust. Näiteks 10 tunnise töö korral, millest 2 on ületunnitöö, tasustatakse 8 tavalise tariifi ja 2 ületunnitariifi järgi.
[image: ]
[bookmark: _Toc370797723]
Plaani täpsustamine

Esimese sammuna tuleb kontrollida, kas plaan sisaldab kogu vajalikku infot ja on piisavalt täpne. Kas kõik eesmärgid on kajastatud ja vajalikud tööd kirja pandud? Kas kõik ressursid on arvesse võetud ja kas need on planeeritud ajal kättesaadavad?
Teise sammuna püütakse plaani võimaluse piires paremaks muuta. Võimalik, et ressursse lisades, töid paralleelselt teostades, mõnest vähetähtsast tööst loobudes jne saab projekti varem lõpetada.
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Kõigepealt tuleb kontrollida, kas plaani koostamiseks kulunud aja jooksul pole projekti eesmärgid muutunud ja kas need on piisavalt konkreetselt sõnastatud.
Võivad muutuda esialgsed eeldused.:
· millist mõju avaldavad suhted tellija ja alltöövõtjatega;
· kuidas mõjutab tööde käiku tööjõu kvalifikatsioon;
· kas materjalide maksumus jääb töö jooksul stabiilseks, suureneb või väheneb;
· kuidas mõjuvad välisfaktorid, näiteks ilm, tööjõupuudus jne?
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Kui esialgsed eesmärgid on muutunud, muutub ka nende saavutamiseks vajalike tööde loetelu, mõningaid töid tuleb lisada ja/või üleliigseid kustutada. Näiteks on mõni töö jäänud kahe silma vahele.
Tööde loetelu võib muutuda ka seoses sellega, et väiksemad, vähem tähtsad tööd liidetakse või suuremad tööd jaotatakse osadeks.
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Kui plaani koostamise ajal võetakse aluseks tööde algustähtaeg, arvutab MS Project nende lõppemise tähtaja. Enamasti kulub tööde täitmiseks rohkem aega, kui on tellijale vastuvõetav. Töödeks kuluvat aega saab lühendada  mitmel viisil:
· vähendades kriitilisel teel paiknevate tööde tegemiseks vajalikku aega (eraldades mõnele tööle rohkem ressursse);
· vähendades projekti mahtu, st jättes osa töid ära;
· alustades mõningaid töid varem, kui esialgselt planeeritud.
Kriitiline tee on nende tööde jada, mis määrab projekti lõpptähtaja. See algab projekti alguskuupäevast ja lõpeb lõppkuupäevaga. Kriitilise tee esiletõstmiseks kuvatakse vaadetes Network Diagram, Tracking Gantt ja Detail Gantt sellel olevad tööd punaselt. 
Kriitilisel teel olevaid töid võib kuvada Gantti diagrammil, rakendades spetsiaalset filtrit: View -> Resource Views -> Resource Usage (Resource Sheet, Other Views) -> Detail Gantt. Pärast filtri rakendamist kuvatakse kriitilisel teel paiknevad tööd punaselt.
Tuleb kontrollida, kas kõik kriitilisel teel paiknevad tööd on ikka tõepoolest omavahel seotud ja kas ühtki neist ei saa teistega paralleelselt teha. Edasi tuleks kontrollida, kas mõnele kriitilisel teel paiknevale tööle pole asjatult kehtestatud jäika algus- või lõpptähtaega, mille eemaldamine võimaldaks projekti lõpptähtaega ettepoole nihutada.
Projekti lõpptähtaeg sõltub eelkõige pikematest kriitilisel teel paiknevatest töödest, mis võib Gantti diagrammil sortida pikkuse järjekorda. Selleks:
1. valige Gantti diagrammil Project -> Filtered For -> Critical;
2. View -> Data -> Filter ja sealt Critical;
3. valige View -> Data -> Sort alt Sort By... võimalus Duration ja klõpsake raadionuppu Descending;
4. klõpsake nuppu Sort.
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Kõigepealt kontrollige, kas mõnd kriitilisel teel paiknevat tööd ei saa hoopis ära jätta või teha paralleelselt teiste töödega. Kui ärajäetud töö oli eelneva ja järgneva tööga seostatud FS-sidemega, siis seotakse automaatselt kustutatud tööle eelnenud ja järgnenud töö sama tüüpi sidemega.
Järgnevalt tuleb ükshaaval kontrollida kriitilisel teel paiknevate tööde kestust, alates kõige pikematest töödest.
Kui töö mahtu ei saa vähendada, tuleb töö jaoks eraldada rohkem ressursse. Selleks klõpsake töö nimel ja siis tööriistariba nupul Assign Ressources [image: ]. Ühe ressursi lisamiseks valige dialoogiakna väljalt Name vajaliku ressursi nimi ja näidake selle kasutamise ühikuks 100%, kui töötaja on plaanitava tööga hõivatud kogu tööpäeva jooksul (kahe korral vastavalt 200%, kolme korral 300% jne).
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Tööde planeerimisel võib osa ressursse jääda ala- või ülekoormatuks. Plaani täpsustamisel tuleb kontrollida ressursside koormust ja püüda ülekoormust vältida või vähendada. Ülekoormuse likvideerimiseks tuleb:
· muuta töö mahtu (task properties);
· muuta ressursside eraldamist (assignments);
· muuta ressursi tööaja pikkust (working time).
Ülekoormuse leidmiseks:
1. View -> Resource Views -> Other Views;
2. valige Resource Allocation ja klõpsake Apply;
Ülekoormuste likvideerimiseks võib seda põhjustava töö algust käsitsi edasi lükata (delay), kuni ressurss vabaneb.
Algustähtaja nihutamiseks:
1. avage vaade Resource Allocation ja ressursside juhtimise tööriistariba;
2. ülemises aknapooles klõpsake ülekoormatud ressursi nimel;
3. alumises aknapooles klõpsake töö nimel, mille jooksul ressurss on üle koormatud;
4. väljale Leveling Delay (paikneb töö nime järel) tippige töö algse nihke väärtus;
5. vajutage Enter (töö nihutamist näitab Gantti diagrammil eelneva töö riba otsast jätkuv peenike joon).
Kui ülekoormust põhjustavaid töid on palju, võib nende algusi ka automaatselt edasi lükata ja hiljem vajaduse korral üksikute tööde nihke suurusi täpsustada. Selleks  valida Tools -> Resorce Leveling.

Ülemises kastis Leveling Calculations klõpsake Automatic  ja valige nihutamise baas (vaikimisi Day by Day).
[image: ]Keskmises kastis määrake, kas ülekoormust põhjustavaid töid nihutatakse kogu projekti või määratud ajaintervalli ulatuses.
Alumises kastis Resolving Allocations valige loetelust nihutamistingimuste tähtsusjärjekord, märgistage vajalikke tingimusi sisaldavad kontrollkastid ja klõpsake Level Now.


Ülekoormatud ressurssi võib kasutada osalise tööajaga. Puudujääva töömahu katteks tuleb leida lisaressurss.
Ressursi kasutamiseks osalise tööajaga:
1. avage Gantti diagramm;
2. klõpsake vajaliku töö nimel;
3. klõpsake tööriistariba nupul Assign Resources;
4. valige ressursi nimi;
5. tippige väljale Units osalist tööd väljendavate ühikute arv (näit 25%);
6. vajutage Enter.


[bookmark: _Toc370797729]Tööde maksumuse kontrollimine

Projekti maksumus sõltub tööde mahust, kasutatavate materjalide ja ressursside maksukusest ning asutuse üldkuludest.
MS Project võimaldab kuvada:
· projekti kogumaksumuse;
· üksiku töö kogumaksumuse;
· ressursi kasutamise kogumaksumuse;
· üksiku ressursieraldise maksumuse;
· kulutuste ajalise jaotuse.
Projekti kogumaksumuse vaatamiseks:
1. valige Project -> Project Information;
2. klõpsake nupul Statistics (rida Current veerg Cost).
Üksikute tööde kogumaksumuse vaatamiseks:
1. avage Gantti diagramm;
2. valige menüüst View -> Data ja sealt Table -> Cost;
3. pukseerige vertikaalset jaotusjoont paremale, kuni on näha veerg Total Cost.
Ressursi kasutamise kogumaksumuse vaatamiseks:
1. klõpsake vaatepaani nuppu Resource Sheet;
2. valige View -> Data ja sealt Table -> Cost;
3. ressursi kasutamise kogumaksumused on väljal Cost.
Kulutuste ajalise jaotuse vaatamiseks:
1. klõpsake vaatepaani nupul Task Usage;
2. valige View -> Data ja sealt Table  -> Cost;
3. aknas on näha kulutuste ajaline jaotus päevade kaupa.
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MS Project võimaldab kasutada mitmesuguseid vaateid, tabeleid vorme ja filtreid.
Vaated esitavad tööde või ressursside kohta käivat infot kindlas vormingus: diagrammi, tabeli, vormi või nende kombinatsioonina. Enamik vaateid võimaldab infot sisestada ja redigeerida.
Tabelites paikneb info veergude ja ridadena. Igas veerus on kindlat tüüpi info (näiteks töö alguskuupäev).
Filtrid võimaldavad kuvada teatud kriteeriumile vastavat infot (näiteks lõpetatud tööd).


[bookmark: _Toc370797731]Vaated

Vaateid saab valida View -> Resource Views ja sealt Other Views -> More Views...
Enamus neist vaadetest on nähtavad ka View Bar’il, mille saab tekitada vajutades hiire paremale klahvile.
Enam kasutatav vaade on Gantti diagramm (Gantt Chart), milles tööde kohta käiv tabelinfo on ühendatud diagrammiga, mille ribad kujutavad tööde pikkust ajateljel. Hiirega pukseerides võib muuta tööde järjekorda, nende pikkust ja algusaega. Paremklõps ribal avab hüpikmenüü, milest saab avada töö kohta käiva info sisestamise akna (Task Information), märkuste akna (Task Notes), pikema töö osadeks jaotada (Split Task) või riba vormindada (Format Bar). Paremklõps tühjal kohal avab hüpikmenüü mitmesuguste lisakorraldustega, sh Gantt Chart Wizard, mille abil saab diagrammi välimust muuta.
Teiseks infoesitusviisiks on võrkdiagramm (Network Diagram), millel tööd on kujutatud nooltega ühendatud ristkülikutega. Ristkülikus on töö nimi, järjekorranumber, algus- ja lõppkuupäev ning kestus. Paremklõps ristkülikul avab hüpikmenüü, mille korraldustega saab avada aknaid töö kohta käiva lisainfo vaatamiseks, sisestamiseks või muutmiseks.
Paremklõpsuga tühjal kohal saab akent suurendada, pooleks jaotada ja diagrammi vormindada.
Kalendrivaatel (Calendar) on tööd paigutatud kuukalendrile. Paremklõps töö nimel avab hüpikmenüü, kust saab avada aknaid töö kohta käiva lisainfo vaatamiseks, sisestamiseks või muutmiseks. Järgmise või eelmise kuu kalendri kuvab hiireklõps kuu nimevälja kõrval paiknevatel noolenuppudel.
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Iga töö ja ressursi vaatega on alati seotud mingi kindel tabel. MS Project’i andmebaasi tabelite sisu on ette määratud, kuid kasutaja võib veerge või koguni uusi tabeleid lisada. Kui soovite antud vaates vaadelda mingit muud tabelit, tuleb valida View ->Data -> Table ja klõpsata vajaliku tabeli nimel.
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Filtrid

Filtri rakendamisel kuvatakse ainult filtreerimistingimustele vastav info. Filtrid jagunevad kahte gruppi: tööde filtrid ja ressursside filtrid. Kasutada saab kolme tüüpi filtreid: standartne, automaatne (AutoFilter) ja kasutaja poolt koostatud (interactive filter).
Standardsed filtrid põhinevad ühel või kahel enamkasutataval tingimusel, mis valitakse menüüst View -> Data -> Filter. 
Kasutaja võib talle sobiva filtri ise koostada. Selleks tuleb avada suvaline vaade (v.a. võrkdiagramm). Valida View -> Data ja sealt Filter  -> New Filter. Väljale Name tippige filtri nimi. Valige loetelust või tippige väljadele sobivad väärtused. Tabeli kohal paiknevate nuppudega saab tabelist tingimusteridu kustutada, kopeerida, uusi ridu olemasolevate vahele lisada jne. Lõpuks klõpsake OK ja filtrivalikuaknas nupul Apply.
Filtri eemaldamiseks valige View -> Data  ja sealt Filter -> No Filter.
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Printida saab vaateid ja aruandeid. Vaate printimiseks jagatakse ekraanil olev info lehekülgedeks. Aruannete printimiseks tuleb valida Project -> Reports ja sealt Reports, kust on võimalik valida vajalik aruandegrupp ja sellest konkreetne aruanne. 
[image: ] 
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Valitud aruannet võib redigeerida nupuga Edit. Klõps nupul Select kuvab aruande prindivaateaknas. Pärast muudatuste tegemist kontrollige dokumendi välimust prindivaateaknas (Print Preview). 
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Tööde käigu kontrollimine

Tegelik elu sunnib muutma ka kõigetäiuslikumat plaani, sest tööd ei valmi alati planeeritud tähtajaks, maksavad planeeritust rohkem jne. Tööde käiku tuleb pidevalt jälgida, plaaniga võrrelda ja selle alusel plaani korrigeerida.
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Esimeseks sammuks on protseduur, mida nimetatakse setting the baseline (edaspidi kontrolljoon). Kontrolljoon on kriitiliste andmete kogum, millega võrreldakse reaalseid andmeid, et kindlaks teha, kas tegelik tööde käik ennetab plaani või jääb sellest maha. Enne kontrolljoone kehtestamist tuleb veenduda, et:
· tööde algus- ja lõpptähtaeg on kooskõlastatud;
· projekti, brigaadide ja üksiktöötajate tööajakalendrid on koostatud ja kooskõlastatud;
· tööde loetelu sisaldab kõik vajalikud tööd;
· kõik ressursid on arvesse võetud (loetellu kantud);
· igale tööle on kinnistatud vähemalt üks ressurss;
· [image: ]ressursid on ühtlaselt koormatud, ülekoormused on kõrvaldatud;
· kriitiline tee on muudetud võimalikult lühikeseks;
· töödevahelised seosed vastavad tegelikule tööde järjekorrale;
· üleliigsed kitsendused on kõrvaldatud;
· kõik asjatud töödevahelised ooteajad on kõrvaldatud (kõik tööd algavad nii pea kui võimalik);
·  plaaniline tööde maksumus on aktsepteeritud.
Kontrolljoonte salvestamiseks:
1. Project -> Scedule -> Set Baseline;
2. valida raadionupud Set baseline ja Entire project ja seejärel OK.


Kui soovite hiljem võrrelda esialgse kontrolljoonega plaani andmeid muudetud plaanivariantidega, tuleb algse kontrolljoonega plaani koopia salvestada eraldi failina. Selleks:
1. Fail -> Save As;
2. File name – nimetus, mis tuletab meelde, et tegu on esialgset kontrolljoont sisaldava plaanivariandiga;
3. Save.
Pärast mitmete muudatuste tegemist võib tekkida vajadus salvestada vahevariandid (interim plan). MS Projekt võimaldab salvestada kuni 10 vahevarianti. Selleks tuleb avada Project -> Scedule -> Set Baseline, märgistada raadionupp Save interim plan, valida väljalt Copy salvestatava plaani nimi, kasti Into vahevariandi nimi ja märgistada raadionupp Entire project või Selected tasks.
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Tööde käigu kontrollimine

Et võrrelda tööde tegelikku käiku planeerituga, tuleb operatiivselt laekunud andmeid sisestada järgmistele andmebaasiväljadele:
	Kontrollitav info
	Kuhu sisestatakse

	Töö alustamise kuupäev
	Actual Start

	Töö lõpetamise kuupäev
	Actual Finish

	Valmidusprotsent
	Percent Complete

	Kestus
	Actual Duration

	Maksumus
	Actual Cost

	Töö maht (work)
	Actual Work


Töö korraldamisega pannakse paika, kes vastutab õige info edastamise ja sisestamise eest, millal ja kui tihti seda tehakse.
Kuupäevade asemel võib juba tehtud töö tegeliku kestuse tippida sama akna väljale Actual dur. Siis arvutatakse töö alguskuupäev, valmidusprotsent ja järelejäänud päevade arv. Kui sisestatud tegelik töö kestus ületab planeeritu, siis MS Project suurendab planeeritud töö kestust, muudab järelejäänud töö kestuse nulliks ja näitab valmidusprotsendiks 100%.
Tegeliku kestuse asemel võib väljale % Complete tippida valmidusprotsendi, mille alusel arvutatakse alguskuupäev, tegelik kestus ja järelejäänud päevade arv.
Kui töö on lõppenud, tähistab seda Gantti diagrammil linnuke töö nime ees. Töö tegelikku pikkust näitab diagrammil pidev joon.
Nupuga Notes saab avada akna lisainfo sisestamiseks (näiteks miks töö lõpetamine hilines).
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Tegelikku tööde käiku tuleb võrrelda esialgse plaaniga kehtestatud kontrolltähtaegadega, et teha kindlaks hälbed. Eesmärk on kindlaks teha:
1. tööd, mis pole alanud või lõppenud planeeritud tähtaegadel;
2. tööd, mis edenevad planeeritust aeglasemalt;
3. tööd, mille maht osutub planeeritust suuremaks või väiksemaks.
Võrdlust kontrolljoonega aitavad visualiseerida edenemisjooned (progress lines). Nende kuvamiseks:
1. avage Gantti diagramm;
2. Tools -> Tracking -> Progress Lines;
3. dialoogiaknas lehel Dates and Intervals märgistada kontrollkast Always display current progress line;
4. klõpsata raadionupul At current date;
5. valida edenemisjoonte intervall (nt Weekly);
6. klõpsata raadionupul Baseline plan;
7. klõpsata OK.
[image: ]
Vertikaalsed edenemisjooned lisatakse Gantti diagrammile. Töödega ühendab neid V-kujuline jõnks. Kui V-tipp on suunatud vasemale, jääb tegelik tööde käik kontrolljoonest maha, kui see on suunatud paremale, edestab tegelik tööde käik kontrolljoont.
Tööde käiku võib kontrolljoontega võrrelda ka tabelite abil. Kontrolljoonte salvestamisel täidab Project tabelite veeru Baseline väljad. Kui tööde käigu kohta sisestatakse andmeid, arvutab Project hälbe kontrolljoonest ja kannab selle väljale Variance.
Hälvete vaatamiseks klõpsata vaatepaneeli nupul Tracking Gantt, valida Tools -> Table ja klõpsata alammenüü real Variance.
Kui mõni töö algab planeeritust hiljem, algavad samavõrra hiljem ka kõik sellea seotud tööd ning nihkub projekti lõpptähtaeg. Tähtis on kõrvalekalded õigeaegselt avastada.
[bookmark: _Toc370797739]
Infovahetus

MS Project’i andmebaasis olevat infot saab vahetada teiste Microsoft Office’i programmidega, andmeid saab eksportida ja importida teiste firmade programmidesse.
Infovahetuseks on mitu võimalust:
· korraldused Copy ja Paste;
· andmete eksportimine ja importimine;
· seostatud objektide või hüperlinkidepaigutamine Project’i andmebaasi.
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Teksti või graafika kopeerimine:
1. märgistada lähtefailis vajalik objekt ja anda korraldus Copy;
2. muuta aktiivseks sihtfaili aken, viia kursor vajalikule kohale ja anda korraldus Paste.
Sihtdokumendis peab olema piisavalt ruumi kopeeritava teksti või pildi paigutamiseks.
Gantti diagrammi tabeli pesadesse saab kopeerida ainult teksti. Kui kursor on aga veeru Indicators mõnes pesas, saab diagrammiosale lisada pildi, mille võib paigutada ribadest vabale pinnale.


[bookmark: _Toc370797741]Objektide lisamine ja seostamine

Seostatud info kopeerimiseks tuleb see lähtefailis märgistada, kopeerida mälupuhvrisse ja paigutada sealt sihtfaili sobivale kohale korraldusega Paste Special. Selle korraldusega avanevas dialoogiaknas tuleb klõpsata raadionupul Paste Link ja valida väljalt As sobiv andmetüüp.
Objektide lisamisel ja nende seostamisel tuleb silmas pidada, et neid saab paigutada vaid selleks sobivale kohale (tekst saab paigutada tabelitesse ja pilte graafikaväljadele või aruannetesse). Veergudes paikneva teksti korral peavad ka sihttabelis olema samad veerud.


[bookmark: _Toc370797742]Eksportimine ja importimine

Teiste programmidega koostatud infot võib importida Project’i andmebaasi ja Project’i andmebaasis paiknevat infot võib eksportida teistesse programmidesse.
Andmete eksportimiseks:
1. File -> Save As;
2. väljalt Save in valida kaust, kuhu soovite andmeid eksportida;
3. loetelust Save As valida sobiv failivorming;
4. klõpsata faili nimel, kuhu andmeid eksportida, või tippida uus faili nimi, edasi klõpsata Save. Kui valitud fail on MPP-, MPX- või MPT- vormingus, algab salvestamine, vastase korral avaneb dialoogiaken Export Mapping;
5. valitud andmete salvestamiseks avada akna leht Selective data ja klõpsata ühel standardsetest import/eksport-mallidest (määravad, mis nimega väljadele tuleb sihtfailis kirjutada Project’i andmed), vajadusel redigeerida malli nupuga Edit avanevas aknas või koostada nupuga New Map uus mall ning lõpuks klõpsata Save.
Import/eksport-malli defineerimisaken (Define Import/Export map) on vahend, mille abil määratakse, millised väljad projekti andmebaasist eksporditakse ja millise nimega väljadele info paigutatakse, et Access, Excel või Word seda lugeda oskaksid.
Andmete importimiseks:
1. klõpsata nupul Open;
2. dialoogiaknas File Open valida väljalt Look in vajalik kaust;
3. välja Files of type loetelust valida vajalik failitüüp;
4. klõpsata failide loetelus vajaliku faili nimel ja siis nupul Open. Kui imporditakse mõni MPP-, MPX- või MPT-fail, milles on terve projekt, siis see avatase. Osaliste andmete või teistsuguse failitüübi korral avatakse dialoogiaken Import Mapping;
5. osaliste andmete importimiseks klõpsata raadionupul Selective Data ja valida loetelust üks olemasolevatest import/eksport-mallidest, või koostada nupuga New Map uus mall ja klõpsata nupul Open.

	Monika Aas
	11



image4.tmp
Gantt Chart Tools

o o s cOa
— - EEmes Tiene LN B Inspect o summary 5] -« a8
- ., 7 Respect Links 5 Move @ Milestone =] @
BLU|D A RS Cpnuate | S sinesue | B ode L 1 P
Clipboard_| Font | Schedue | Tasks | Insert | propeties | editing |
e = - _mm.m . [start o Finish  |Predecessor 26 Aug 13 25ep 13 55ep 13
Mode WITTF[sTsM[TW[T[F[s[s[M[TW[T[F[s[s[M[TW[T]F
1 2 toa tahjendamine 1day Thu22.08.13  Thu22.08.13
2 2 166 seintega 0days. Thu22.08.13  Thu22.08.13 2208
3 =3 vana tapeedi 2days Thu22.08.13  Fri23.08.13
eemaldamine
a 2 166 laega 0days Thu22.08.13  Thu22.08.13 2208
s =3 lae puhastamine vanast 2 days. Thu22.08.13  Fri23.08.13
varvist
6 2 Iae pahteldamine 2days Thu22.08.13  Fri23.08.13
7 2 lae varvimine 2days Thu22.08.13  Fri23.08.13





image5.tmp
Gantt Chart Tools
=

ormat

Task | Resource  Project  View

P ] = Mark on Track ~ * Dispect - gy e Summary [N} q} -
- = Respectlinks B move - @ Wilestone 2-
BIu o Manually Task Information ;| Srall
U % o inactivate = P Mode | iz Delverable | o @
Ciipboard Font ® Schedule Tasks Insert Properties Editing
e = - Duration , |start L [Finish  |Predecessor £'13 26 Aug 13 2513 Ssep'1s
Mode WITTF[sTs[M[TW[T[F[s[s[M[T[W[T[F[s[s[M[TW[T]F
1 2 toa tuhjendamine 1day Thu22.08.13  Thu22.08.13
= 100 seintega Todays Thu22.08.13 Thu22.08.13 1 2208
=) vana tapeedi 2days. Fri23.08.13 Mon26.08.13 2
eemaldamine
=) 06 laega 0days. Mon 26.08.13 Mon 26.08.13 3 26.08
=3 lae puhastamine vanast 2 days. Tue27.08.13 Wed28.08.13 4
varvist
=) Iae pahteldamine 2days. Thu29.08.13 Fri30.0813 5
=) lae varvimine 2days. Mon2.09.13 Tue3.09.13 6 -





image6.tmp
Gantt Chart Tools

Task | Resource  Project  View Format @@ &
h - eEses P Mark on Track ~ * Dinect - g P summary ] q} A
= Respectlinks B move - @ Wilestone 2-
U &-A- Manually Task Information ;| Srall
° =3 Schedule| B moge- | ST g Deiverable & | toTask @~
Schedule Tasks Insert Properties Editing
Duration _, [Start L [Fimish  [predecessor £ 13 26 Aug 13 2513 Ssep s~
Mode WITTF[s[sM[T[W[T[F[s[s[M[T[W[T[F[s[s[M[TW[T[F[=
=) toa tihjendamine 1day Thu22.08.13 Thu22.08.13
3 © 86 seinte 2 Fri23.08.13  Mon26.08.13 1
ega
=3 vana tapeedi 2da Fri23.08.13  Mon26.08.13
ys
eemaldamine
3 85 I 6 Tue27.0813 Tue3.09.13 3
laega
=3 lae puhastamine  2da Tue27.0813  Wed28.08.13
P Vs
vanast varvist
= lae pahteldamine ]2 da Thu29.0813 Fri30.0813 5
pal Vs
= lae varvimine 2days. Mon2.09.13 Tue3.09.13 6 -





image7.tmp




image8.tmp




image9.tmp
Resource Sheet Tools

B - | oo Poed vew | roma o€

@ 3; — i eEseg THwews g -:> Dimpect - gy wwsummany _‘}2.

 IRespectlinks 5 Move - @ Milestone =
Son| ™ g s u @A = S| A g | ™ e | | S
view | _cipboard |_ront s s | et e
s < [Moterial__~ [imitials_~ [Group = |Max__~ [stdRate_~ [Ovt Rate_~ [Gost/Use _~ |Accrue At | 5ase Calen
maaler Work m 100%  5,00€/hr 7,00 €/hr 0,00€ Prorated  Standard
2 parketipanija Work 3 100%  4,00€/hr  6,00€/hr 0,00€ Prorated  Standard
3 pahtel Material b 16,00€ 0,00€ Prorated
4 laevarv Material 1 10,00€ 0,00 € Prorated
5 seinavarv Material s 12,00€ 0,00 € Prorated





image10.png
Change Workng T N G
or corors S BrojectColed) B
T

Cldkon a day to see its working times:

September 2013 '+ Working tmes for 11 September 2013:
MIT]wlmh[F[s]s

s 00 to 12:00
1300 to 17:00
2[5 |2 [5]6]7
B m-u 13|18
Based on:

(17

3
3
B

> Defaut work wesk on calendar ‘Standard.

25|28 |25 |26 |27 |28

E)
Exceptions | Work Weeks

Name Start Fiish - Detais.

Il Delete





image11.tmp




image12.png
e e
Task: toa tihjendamine
(&) Resmace st apins
Resources from tuba-tekst.mpp
T = (o=
Resowcename [wp[unts[cost &

Hold don Cirl and cick to select multiple resources

Remove
Repiace.

Graph

[ ek





image13.tmp




image14.png




image15.tmp
Information




image16.png
Display.
e
—
==
oo

Trust Center

Advanced options for warking with Project.

General

Set AutoFilter on for new projects
Brompt for project info for new projects
Show add-in user nterface errors.

Project Web App.

[ Allow team members to reassign tasks





image17.png
@ Microsoft Project - toa remo =]

HG) He ot wew Dt Fomak s Popa Colsborote Mindow Hep Tipe s quesionfor e+ @ X
DS HR S 6B S8 = 35860 L] B | veon RRT|©
Pe 9 4 = b show- | speling| -8 - .1 u \. = | all Tasks B

2 [rst] - | Resowces < | Trock - | Report - |

to5 laega

© [Task Name. Durstion| Sttt Fiish T4 Jan 08 21 Jan'a <
FIS[SM[T WIT[F[S[S|M[TWIT[F[S]S

[ toatinendanine T day Mon 140108 Mon 140108
vana tapeed cemakiamine __ #b###H_Tue 15.01 08 Wed 16.01 08 tapectia

;
:

B XTI o i s
:
:
:

Toe pustaminG vanast var 2 days Wed 16.01.08 Fri18.01 08
lae patteldamine 2days Fri180108 Tus 220108
lae varvinine 2days| Tue 220108 Thu240108

< 2l |

o [Foe e P = |
St W50 5 =] Fig [Tz or s o] Tesktyme [ ] e conglete: [
1 [Resource Nome Unts | Work |ove. Work|_Basene Work | Act Work | Rem, Work

2 Jloteatn e oo o Jn

Ready [




image18.tmp




image19.png
Leveling calcultions

 automatic & tanual

Laok for gveralocations ana [Day by Day | basis

IV Clear leveiing valuss before leveling

Leveling range for 't remont.mpp"
 Level entire project

Clevel grom: [Fon 170108

Le

To: [Tuzsor08

Resolving overalocations

Leveling orer:  [Standerd

T~ Levelonly within avaiable slack

[V Leveling can adjust individual assignments on a task.
[V Leveling can create splits in temaining work.
I~ Level resources with the proposed booking type

v | corioveing. | v | [T

Cancel





image20.png
1 ;H ;n

fssgments..  workioad, custom

0





image21.png
Overview Reports

Broject summary.

it Tasks





image22.png
) Setinterim plan
Copy: [Schedued Start/Fiish
Into: [Starty/Frisht

I
Entire project I
Selected tasks. |
Rollup baseines: I

To ol summary tasks
Erom subtasks nto selected summary task(s)

Setas Default

Lo ] [ ][ewm)





image23.png
Progress

oseandiionds |
[ hlways display current progress line

C Atproject statusdate At cunret date.

o ts |

(T Display selected progress lines

[ Display progress lines at recurting interyals

Progress Line Dates

 Daily & weekly  Monthly
sty
Mhen  MIue [ wed
M MEi Msat s

Begn at:

 projectstart

ooe

¢ [Fen 10.05.06 5]

Display progress ines i relation to
 fctual plan

 aseling plar)

b

Cancel





image1.tmp
Gantt Chart Tooks =

0=
Troontaccr o p @ Guwpea g Fvsumnay == A
2 Respectlinks B move @ Milstone a-
5 - " Manualy _Auto Task Informstion | scrll
% = nactuate Simeinte scncute | B Mode | "5 iz eiveravle @ | otk @-
e scnaute | e I e
start finish
220833 220833
Task . TaskName . Duration , [start J[Fnish . [Predecessor 26 AR TS P55 EETRE) <
Mode TIFIS TS [MIT [WITTF[STS [MIT WITTFIS S [MITIW[TTFIS]=]
<@ vl ®
T e e





image2.png
Project Information for Projectl’

Startdate:  Thu22.08.13 + Curentdate: Thu22.08.13 -

Bshdate:  [Tuzzonig 4 2SS P oo A -
E [z et s
Schede fom:  ProectStartl ool 1 g 3 4 | Cdendars  Stendard -

| 5678351011
Altasksbegnasst 13 13 14 13 16 17 18
Enterprise Custom Fields

Department: EEE e
[ i

T day

priority:

3





image3.tmp
Gantt Chart Tools.
=

o o s Y
— n - EEmes Thewe 5 O S o Summary [S] o« -
G- 2 Respectlinks S | o @ Miestone a-
Paste BIu Etes) Manually _Auto Task Information | Scrall
R ° % S nadtivate Schedule Scheduie | [ Mode ~ | .7 i Deliverable E | toTask @
Ciipboara_| Font Schedule | Tasks | Insert | properties | _eaiting_|
e = - Duration , |start L [Finish  |Predecessor £'13 26 Aug 15 FETRE) EETRE)
Mode WITTF[sTsM[TW[T[F[s[s[M[TW[T[F[s[s[M[TW[T]F
1 2 toa tahjendamine 1day Thu22.08.13  Thu22.08.13
2 =3 vana tapeedi 2days Thu22.08.13  Fri23.08.13
eemaldamine
3 =3 lae puhastamine vanast 2 days. Thu22.08.13  Fri23.08.13
varvist
a 2 Iae pahteldamine 2days Thu22.08.13  Fri23.08.13
s 2 lae varvimine 2days Thu22.08.13  Fri23.08.13





